Saturday, December 30, 2017

all lower case file names


if you need to convert every file to lower case in a folder in OS X this command will do that.


for f in *; do mv "$f" "`echo $f | tr "[:upper:]" "[:lower:]"`"; done

Tuesday, December 19, 2017

Creating a bootable USB or SD on OSX

First, verify the path to your SD card. You can do this by running the following command from terminal: 
diskutil list
The output shows a list of disks currently mounted on the system. Here's the relevant line from my output: 
/dev/disk3
#:                       TYPE NAME                    SIZE       IDENTIFIER
0:     FDisk_partition_scheme                        *8.0 GB     disk3
1:                 DOS_FAT_32 RPISDCARD               8.0 GB     disk3s1
In this case I can verify /dev/disk3 is my SD card because the TYPE, NAME and SIZE values are correct. 
If you have an existing partition on the disk you may need to unmount it, otherwise you'll get a "Resource busy" error message when you try to write the image. 
diskutil unmount /dev/disk3s1
Now to write the image file to the disk. Note the 'r' added to rdisk3 which drastically improves write performance by telling dd to operate in raw disk mode:
sudo dd if=RetroPieImage_ver2.3.img of=/dev/rdisk3 bs=1m
Depending on the size of your SDcard this may take a while. You can press CTRL+T to see the current status of dd. As an example for my Samsung 8GB SD card the write speed was 12MB/s the command took 11mins to complete.

Friday, December 8, 2017

HP 800 G1 upgrade 10.13.1 to 10.13.2

if you are going to upgrade from 10.13.1 to 10.13.2 follow these steps for a efforts free upgrade

first upgrade clover to r4334
then download the follow kext and put the in your kexts EFI folder
Lilu.txt version 1.2.1
NvidiaGraphicsFixup.kext 1.2.1 <- if you have an Nvidia graphics card

The reboot
now you can upgrade from the App Store to 10.13.2 - failing to do so will cause your 800 G1 to not boot