if you need to convert every file to lower case in a folder in OS X this command will do that.
for f in *; do mv "$f" "`echo $f | tr "[:upper:]" "[:lower:]"`"; done
diskutil list
/dev/disk3
#: TYPE NAME SIZE IDENTIFIER
0: FDisk_partition_scheme *8.0 GB disk3
1: DOS_FAT_32 RPISDCARD 8.0 GB disk3s1
/dev/disk3
is my SD card because the TYPE, NAME and SIZE values are correct. diskutil unmount /dev/disk3s1
rdisk3
which drastically improves write performance by telling dd
to operate in raw disk mode:sudo dd if=RetroPieImage_ver2.3.img of=/dev/rdisk3 bs=1m
CTRL+T
to see the current status of dd
. As an example for my Samsung 8GB SD card the write speed was 12MB/s the command took 11mins to complete.